Stage Pro-sound
Stage Pro-lighting
Tube Amplifier
Disco Bar
Karaoke & Bistro Systems
Phone: +84 903 923 527
Welcome, Guest
Username: Password: Remember me

TOPIC: Help Please!!! Weird Tube Amp Issues!!!

Help Please!!! Weird Tube Amp Issues!!! 14 Dec 2017 20:26 #2561

  • Shawnturner
  • Shawnturner's Avatar
  • Offline
  • Senior Boarder
  • Posts: 57
  • Karma: 0
I need some help with an issue I have with my Hot Rod DeVille 4x10. The deal is that I bought a used late 2000's Hot Rod DeVille from a friend that runs a guitar store and I'm pretty sure he took good care of it. I took it to rehearsal yesterday and played it for about 2 and half hours; I ran a Dean Soltero loaded with Seymour Duncans into a Vox Joe Satriani Satchurator pedal and a Dunlop Crybaby Wah. We were doing a demo, so the studio guy ran a line from the Preamp Out to the mixing board with a standard instrument cable.
I played through the clean channel set on about 3, and a little reverb and presence. I would get this distorted sound from the amp (on 3 in the clean channel), where I would expect a fairly pristine clean sound (allowing for the relative effect of the hot SD pickups). In addition, engaging the Drive channel and More Drive (without any overdrive pedal), it sounded really flabby and "farty". Towards the end, when I would switch on the Vox overdrive the volume would drop.
So, at the end of the rehearsal, the amp just dies. It turns off completely, no light, no power, no sound, no nothing; just completely dead. I call my buddy who sold it and he said I might have blown the output transformer because I ran a line from the preamp out to the board, despite the fact that the manual says that is precisely one of its functions. So I bring it home, to take to the shop on Monday to get it checked out. Just out of curiosity I plugged it in the next day and, lo and behold, it switched on and worked. It still had the same distorsion problems on the clean channel (using a different guitar).
Can someone help me out on what this might be, so I don't get screwed by the repair shop guys? It would seem that the distorsion issue and the amp failure issue are due to different problems, but I have NO clue, as this is only my second tube amp in all my life (six months ago I had bought a Peavey 6505+ 1x12 combo, which I sold to buy the Hot Rod, because I play mostly blues and blues based hard rock and I could not get into the amp's distorsion and relative lack of clean headroom, but it never gave me ANY issues at all). I really appreciate all the help you can give!

If anyone has any information about thi,
Please help.

I didn't find the right solution from the Internet.


M2M Marketing Examples
The administrator has disabled public write access.
Moderators: 10
Time to create page: 0.087 seconds

Ad 800x100



Ai đang truy cập

We have 60 guests and no members online

Hôm nay
Hôm qua
Tất cả

21-03-2018 23:43

Đăng ký/đăng nhập

Thảo luận mới